Все записи автора prog

Без рубрики

1с:8.2 (8.3) Управляемое приложение: правильное программное открытие форм

Нашел на просторах https://infostart.ru

Как правильно программно открывать формы:

Нельзя использовать метод ПолучитьФорму()
и другие полезные данные 

  • Как открыть форму объекта имея ссылку на него
  • Как открыть форму выбора произвольного объекта
  • Использование метода ОткрытьФорму()
  • Как открыть форму существующего объекта ссылочного типа
  • Открыть форму существующей записи регистра
  • Как открыть форму нового объекта с обработкой заполнения
  • Как правильно организовать выбор (подбор) в табличную часть
  • Как открыть форму и установить в ней отбор
  • Про Уникальность формы

1с 8.1: Как программно открыть множественный подбор документов (справочников)?

Делаем обработку на примере подбора документа Перемещение товаров.

Создаем обработку. На панели размещаем кнопку Подбор




  
Процедура КоманднаяПанель2Подбор(Кнопка)
    ФормаВыбора = Документы.ПеремещениеТоваров.ПолучитьФормуВыбора(,ЭтаФорма);
    ФормаВыбора.МножественныйВыбор = Истина;
    Если Не ФормаВыбора.Открыта() Тогда
        ФормаВыбора.Открыть();
    КонецЕсли;   
   
КонецПроцедуры

 
 
Процедура обработки подбора
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
МассивВыбранныхЭлементов = ЗначениеВыбора;
Для каждого СтрокаМассива Из МассивВыбранныхЭлементов Цикл
Результат = ТабличнаяЧасть1.Найти(СтрокаМассива,"ПеремещениеТоваров");
Если Результат = Неопределено Тогда
НоваяСтрока = ТабличнаяЧасть1.Добавить();
НоваяСтрока.ПеремещениеТоваров = СтрокаМассива;

КонецЕсли;

КонецЦикла; 

 
ФормаВыбора.Открыть();
КонецПроцедуры
 

 
признак множественного подбора предполагает подбор нескольких позиций в журнале,используя зажаты SHIFT или CTRL.

 
.Команда ФормаВыбора.Открыть();  
использованная в конце последней процедуры, позволяет повторно открыть форму подбора. Конечно, при таком способе журнал будет постоянно закрываться и открываться (будет заметно мигание), но это позволяет несложным способом настроить подбор.

1C 8.x: Пользователи ИБ. Проверить установлен ли пароль у пользователя

Иногда нужно определить у всех ли пользователей установлен пароль, и какие права у пользователя имеются. Получить Имя пользователя (Полное имя пользователея), роли, и проверить установлен ли пароль можно с помощью кода:

Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей(); 
Для Каждого ЭлементМассива Из Выборка Цикл
ИмяПользователя = ЭлементМассива.Имя;
ПолноеИмяПользователя = ЭлементМассива.ПолноеИмя;
ЕстьПароль = ЭлементМассива.ПарольУстановлен;
Роли = ЭлементМассива.Роли;

Для Каждого Роль Из Роли Цикл
ИмяРоли = Роль.Имя;
КонецЦикла;
КонецЦикла;

1с:8.2 Управляемые формы. Как открыть форму элемента справочника

Вот способ открытия формы элемента справочника  в управляемых формах (1с 8.2, 1с 8.3)

Делаем на примере справочника товары


&НаКлиенте
Процедура ОткрытьТовары(Команда)
 Параметр = Новый Структура("Ключ", Товар);
   
Форма = ПолучитьФорму(

"Справочник.Товары.Форма.ФормаЭлемента"
,Параметр);
Форма.Открыть();
КонецПроцедуры


1с 8: Установка сервера 1с 8.3. Ошибка загрузки компоненты testbase

Если инсталлировать сервер 1с 8.3 без платформы, возникает ошибка загрузки компоненты testbase
После инсталляции скопировать в папку с сервером 1С файл testbase.dll и перезагрузиться. Перезапуск служб сервера почему-то не помогает...

1c 8.1 Как найти файлы во вложеных каталогах

Как найти все файлы во вложеных папках? Есть простой способ:



Процедура НайтиВсеФайлы(Путь)
НайденныеФайлы
= НайтиФайлы(Путь, "*.*");
Для каждого НайденныйФайл Из НайденныеФайлы Цикл
Если НайденныйФайл.ЭтоКаталог() Тогда
// Ищем все файлы в найденном каталоге
НайтиВсеФайлы
(НайденныйФайл.ПолноеИмя);
Иначе
// Это файл, выведем его полное имя
Сообщить
(НайденныйФайл.ПолноеИмя);
НовыйЭлемент
= Справочники.Файлы.СоздатьЭлемент();
НовыйЭлемент
.Наименование = НайденныйФайл.Имя;
НовыйЭлемент
.Путь = НайденныйФайл.Путь;
НовыйЭлемент
.РазмерФайла = (НайденныйФайл.Размер())/1000;
НовыйЭлемент
.ПолноеНаименование = НайденныйФайл.ПолноеИмя;
НовыйЭлемент
.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

источник

1c 8.1: Как выгрузить конфигурацию в файл

Иногда спрашивают как в 1с 8.1 можно выгрузить отдельно конфигурацию в файл, не выгружая базу.
Вариант выгрузки такой:


1. Выбираем в меню конфигуратора  - Сохранить конфигурацию в файл


1с 8. Как сохранить конфигурацию в файл

Придумать имя файла. Например, текущая дата, название базы.


1с 8 Диалог. Сохранить как . Сохранение конфигурации в файл

После процедуры сохранения появится надпись:

1с 8.х Сохранение конфигурации в файл завершено