Архив рубрики: 1с:8.х

1с 8.1: Как программно открыть множественный подбор документов (справочников)?

Делаем обработку на примере подбора документа Перемещение товаров.

Создаем обработку. На панели размещаем кнопку Подбор




  
Процедура КоманднаяПанель2Подбор(Кнопка)
    ФормаВыбора = Документы.ПеремещениеТоваров.ПолучитьФормуВыбора(,ЭтаФорма);
    ФормаВыбора.МножественныйВыбор = Истина;
    Если Не ФормаВыбора.Открыта() Тогда
        ФормаВыбора.Открыть();
    КонецЕсли;   
   
КонецПроцедуры

 
 
Процедура обработки подбора
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
МассивВыбранныхЭлементов = ЗначениеВыбора;
Для каждого СтрокаМассива Из МассивВыбранныхЭлементов Цикл
Результат = ТабличнаяЧасть1.Найти(СтрокаМассива,"ПеремещениеТоваров");
Если Результат = Неопределено Тогда
НоваяСтрока = ТабличнаяЧасть1.Добавить();
НоваяСтрока.ПеремещениеТоваров = СтрокаМассива;

КонецЕсли;

КонецЦикла; 

 
ФормаВыбора.Открыть();
КонецПроцедуры
 

 
признак множественного подбора предполагает подбор нескольких позиций в журнале,используя зажаты SHIFT или CTRL.

 
.Команда ФормаВыбора.Открыть();  
использованная в конце последней процедуры, позволяет повторно открыть форму подбора. Конечно, при таком способе журнал будет постоянно закрываться и открываться (будет заметно мигание), но это позволяет несложным способом настроить подбор.

1C 8.x: Пользователи ИБ. Проверить установлен ли пароль у пользователя

Иногда нужно определить у всех ли пользователей установлен пароль, и какие права у пользователя имеются. Получить Имя пользователя (Полное имя пользователея), роли, и проверить установлен ли пароль можно с помощью кода:

Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей(); 
Для Каждого ЭлементМассива Из Выборка Цикл
ИмяПользователя = ЭлементМассива.Имя;
ПолноеИмяПользователя = ЭлементМассива.ПолноеИмя;
ЕстьПароль = ЭлементМассива.ПарольУстановлен;
Роли = ЭлементМассива.Роли;

Для Каждого Роль Из Роли Цикл
ИмяРоли = Роль.Имя;
КонецЦикла;
КонецЦикла;

1с:8.2 Управляемые формы. Как открыть форму элемента справочника

Вот способ открытия формы элемента справочника  в управляемых формах (1с 8.2, 1с 8.3)

Делаем на примере справочника товары


&НаКлиенте
Процедура ОткрытьТовары(Команда)
 Параметр = Новый Структура("Ключ", Товар);
   
Форма = ПолучитьФорму(

"Справочник.Товары.Форма.ФормаЭлемента"
,Параметр);
Форма.Открыть();
КонецПроцедуры


1с 8: Установка сервера 1с 8.3. Ошибка загрузки компоненты testbase

Если инсталлировать сервер 1с 8.3 без платформы, возникает ошибка загрузки компоненты testbase
После инсталляции скопировать в папку с сервером 1С файл testbase.dll и перезагрузиться. Перезапуск служб сервера почему-то не помогает...