Архив рубрики: Работа с файлами

1c 8.1 Как найти файлы во вложеных каталогах

Как найти все файлы во вложеных папках? Есть простой способ:



Процедура НайтиВсеФайлы(Путь)
НайденныеФайлы
= НайтиФайлы(Путь, "*.*");
Для каждого НайденныйФайл Из НайденныеФайлы Цикл
Если НайденныйФайл.ЭтоКаталог() Тогда
// Ищем все файлы в найденном каталоге
НайтиВсеФайлы
(НайденныйФайл.ПолноеИмя);
Иначе
// Это файл, выведем его полное имя
Сообщить
(НайденныйФайл.ПолноеИмя);
НовыйЭлемент
= Справочники.Файлы.СоздатьЭлемент();
НовыйЭлемент
.Наименование = НайденныйФайл.Имя;
НовыйЭлемент
.Путь = НайденныйФайл.Путь;
НовыйЭлемент
.РазмерФайла = (НайденныйФайл.Размер())/1000;
НовыйЭлемент
.ПолноеНаименование = НайденныйФайл.ПолноеИмя;
НовыйЭлемент
.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

источник